LiteSpeed安装出现 Failed to start litespeed解决方案

error

之前,我们给到了在Debian 系统下,手动安装LLsMP(Linux+Litespeed+MySQL+PHP)的方法。最近大皮在HostUs家的VPS测试的时候,却发现出现了Failed to start litespeed的错误。错误提示如下:

/usr/local/lsws/bin/lswsctrl: 236: ./litespeed: not found
[ERROR] Failed to start litespeed!
[ERROR] Failed to start the web server. For trouble shooting information , please refer to documents in “/usr/local/lsws/docs/”.

从过程上看,这个错误出现在填写了资料之后,是程序本身的问题。在LiteSpeed官网仔细查找后发现,主要是因为LiteSpeed 只有商业版才提供提供对64位操作系统的支持,而 标准版(免费版)没有。因为大皮当时的环境是64位的Debian 7,依赖32位库才能安装,泪奔。

不过,解决方法也很简单,安装LiteSpeed之前,执行如下命令即可:

apt-get install ia32-libs

 

No Comments

Leave a Reply

Your email address will not be published. Required fields are marked *